[Freeswitch-dev] SOLVED: Error: "Cannot Initialize [CannotOpenXML Root!]

Michael Collins mcollins at fcnetwork.com
Wed Sep 20 17:38:41 EDT 2006

Update: it seems that when I initially did the install I did it manually
with make, make check, make install, make mods... However, when I did
the follow up build after making my change, I used 'make installall' and
my /usr/local/freeswitch directory had a lot more stuff this time
around.  I'm 99% sure that doing 'make installall' in the first place
would have prevented my issue.  I will test this theory and report back
if it is not the case...






From: Michael Collins [mailto:mcollins at fcnetwork.com] 
Sent: Wednesday, September 20, 2006 2:10 PM
To: Anthony Minessale; freeswitch-dev at lists.freeswitch.org
Subject: Re: [Freeswitch-dev] SOLVED: Error: "Cannot Initialize
[CannotOpenXML Root!]



From: Anthony Minessale [mailto:anthmct at yahoo.com] 
Sent: Wednesday, September 20, 2006 1:38 PM
To: freeswitch-dev at lists.freeswitch.org
Subject: Re: [Freeswitch-dev] SOLVED: Error: "Cannot Initialize [Cannot
OpenXML Root!]


which OS are you running 

CentOS 4.4

FYI, the path separator is definitely forward slash, so the system knows
that it is a *nix variant


That directory should only be . in windows, in unix it's you --prefix
from configure

which defaults to /usr/local/freeswitch 

Interesting.  The files were definitely install in /usr/local/freeswitch
but I definitely don't have a /usr/local/freeswitch/conf which, I'm
assuming, is where the switch_xml.c/switch_xml_open_root routine is
going to be looking by default.  I will re-run configure and specify the
prefix and let you know what happens.  





Anthony Minessale II

FreeSWITCH http://www.freeswitch.org/
ClueCon http://www.cluecon.com/

AIM: anthm
MSN:anthony_minessale at hotmail.com
JABBER:anthony.minessale at gmail.com
IRC: irc.freenode.net #freeswitch

FreeSWITCH Developer Conference
sip:888 at
iax:guest at
googletalk:freeswitch at gmail.com


----- Original Message ----
From: Michael Collins <mcollins at fcnetwork.com>
To: freeswitch-dev at lists.freeswitch.org
Sent: Wednesday, September 20, 2006 3:12:28 PM
Subject: [Freeswitch-dev] SOLVED: Error: "Cannot Initialize [Cannot Open
XML Root!]


I changed SWITCH_PREFIX_DIR in switch_types.h from "." to my actual
source directory which solved the problem.  

Question: what is the preferred method of making sure that
SWITCH_PREFIX_DIR is set properly?  


Freeswitch-dev mailing list
Freeswitch-dev at lists.freeswitch.org
http://www.freeswitch.org <http://www.freeswitch.org/> 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freeswitch.org/pipermail/freeswitch-dev/attachments/20060920/fbf63484/attachment-0001.html 

More information about the Freeswitch-dev mailing list